nnpc.net
当前位置:首页 >> TomCAt的WEBSoCkEtSErvlEt为什么用不了,不是说自... >>

TomCAt的WEBSoCkEtSErvlEt为什么用不了,不是说自...

网站上说,某个东西会在 tomcat8 上删除,刚好你的 Tomcat 是8.0, 可能就是这个原因.所以,要么你使用 tomcat 7 来开发测试,要么放弃这个不标准化的类库,换成标准化的那个 JSR356 WebSocket 1.0 规范来开发,在 JSR 规范出来前可能

jdk 的问题 path 和 JAVA_HOME 是否正确

没装jar吧? java虚拟机! 正常jdk安装的时候 会安装两次,一次是jdk,一次是jre(java运行环境).这两个都安装在一个目录下 比如:java目录下 jdk,jre.

是正常,但不是向楼上所说的Tomcat和Eclipse集成不好的原因这是很正常,你有些更改是需要Tomcat重新加载编译那些文件才能运行的这个不是集成的问题,是Tomcat容器的特点~~

eclipse中. 或者就是安装的版本不正确.32位?64位?windows------------------->preferences--------------->在查询栏输入tomcat---->选择你电脑上安装的tomcat版本.然后选择你安装的路径.确定,将sever设置为enable启动tomcat的时候,需要选择你安装的那个版本.

检查你在装tomcat时选的jdk关联路径是不是正确的和你的jdk环境变量是不是配对了 用简单程序测试一下

JAVA安装版式不需配置环境的.所以肯定不是配置环境的问题.就你以上的情空,我提出几条建议:1.检查jdk安装成功, cmd -> java 回车检查java是否成功2.如果jdk没问题,那就是tomact的问题了.可以考虑重新装.3.正常情况下,tomact启动 http://127.0.0.1:8080有猫头就表示环境成功跟iis没有任何关系.

1. 确定当前JDK版本是否正常 tomcat6以上 需要jdk1.5以上2. 确定端口是否被占用(比如 1. 是否已启动tomcat 可以通过结束所有java进程的方式解决 2. 是否存在其他软件占用比如迅雷 )

FreeBSD5.3,ports安装的tomcat自己装的也是这个问题,从5.0.28到最新的5.5.27都是这样我的jsvc启动文件:#!/bin/shJAVA_HOME=/usr/local/javaCATALINA_HOME=/usr/local/tomcatTOMCAT_USER=tomcatTMP_DIR=/var/tmpOUTFILE=$

你用JDK5.0,而你的Tomcat版本支持不支持这个版本的JDK! 原因是后来较新版本的JDK(例如我使用的JDK1.6)安装完不会自动登记环境变量JAVA_HOME,JRE_HOME.像我在单位的环境,我的用户是受限制的(PowerUser),不方便设

相关文档
网站首页 | 网站地图
All rights reserved Powered by www.nnpc.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com